Service Disruption: Ethereum Network

Incident Report for Uphold

Resolved

This incident has been resolved.
Posted Mar 27, 2026 - 00:59 UTC

Monitoring

The issue affecting Ethereum (ETH) transactions has been resolved.

A fix has been implemented and operations should be back to normal.

We continue to monitor for any outlier situations.
Posted Mar 27, 2026 - 00:24 UTC

Identified

We are currently experiencing delays with Ethereum (ETH) network transactions, affecting both deposits and withdrawals.

The issue has been identified and originates from a third-party service provider. We are actively monitoring the situation and will resume normal operations as soon as the issue is resolved.

Impact: Uphold, Ascent, and Topper

We apologize for any inconvenience and will provide updates as the situation progresses.
Posted Mar 26, 2026 - 23:41 UTC
This incident affected: Deposits & Withdrawals, Topper, and Ascent.